Categories
Wordpress Plugins

Exclude Plugins mendukung WordPress 3.1

WordPress 3.1 baru saja diluncurkan. WordPress versi terbaru ini memiliki banyak perubahan dalam file core-nya sehingga memaksa itx untuk melakukan update plugin buatan itx yaitu Exclude Plugins. Bagi yang belum tahu apa fungsi dari plugin Exclude Plugins akan itx terangkan sedikit. Plugin ini sangat berguna bagi pengguna WordPress Multisite. Plugin ini bekerja dengan cara membolehkan […]

WordPress 3.1 baru saja diluncurkan. WordPress versi terbaru ini memiliki banyak perubahan dalam file core-nya sehingga memaksa itx untuk melakukan update plugin buatan itx yaitu Exclude Plugins.

Bagi yang belum tahu apa fungsi dari plugin Exclude Plugins akan itx terangkan sedikit. Plugin ini sangat berguna bagi pengguna WordPress Multisite. Plugin ini bekerja dengan cara membolehkan sebagian plugin untuk pengguna biasa (included plugins) sementara menyembunyikan plugin-plugin hebat (excluded plugins) hanya untuk si empunya blog multi site tersebut.

Update plugin ini berawal dari komplain pengguna Exclude Plugins yang menyatakan bahwa terdapat error ketika dia melakukan upgrade wordpress ke versi 3.1. Error tersebut bunyinya kurang lebih begini:

Fatal error: Call to undefined function print_plugins_table() in /home/usernamecpanel/public_html/wp-content/plugins/exclude-plugins/exclude-plugins.php on line 156

Kemudian segera itx mendonlot wordpress 3.1 untuk melakukan pengecekan. Seharusnya dari versi 3.1 beta ataupun RC itx sudah mencoba-coba, tapi karena cukup yakin bahwa tidak akan berdampak banyak, maka tidak dilakukan.

Maka pengecekanpun dilakukan dengan pertamakali menginstal WordPress 3.1 di mesin lokal. Dari pengecekan ini disimpulkan bahwa update WordPress kali ini cukup gede-gedean. Salah satu update tersebut adalah digunakannya class WP_List_Table untuk mencetak berbagai macam tabel ke layar. Dengan difungsikannya class itu maka dihapuslah fungsi print_plugins_table(), padahal fungsi itu digunakan oleh Exclude Plugins.

Setelah muter-muter ngubek-ubek file core wordpress 3.1 – yang ternyata banyak file-file baru di dalamnya, dengan hasil nihil, maka itx memutuskan untuk menggunakan cara simpel. Tinggal copy paste saja dari WordPress 3.0 fungsi yang telah dihilangkan tersebut. Dan hasilnya ternyata mujarab, tidak perlu cara susah jika memang ada yang mudah.

Saat ini Exclude Plugin versi terbaru yaitu versi 1.1.3 yang mensupport WordPress 3.1 sudah diupload ke repository plugin wordpress. Silahkan menuju dashboardmu untuk melakukan update 😀 .

Selamat menikmati.

By itx

Simple coder

10 replies on “Exclude Plugins mendukung WordPress 3.1”

Quickbooks error codes 80029c4a is an error that happens while opening a company file. The error message is potentially caused by an incompatibility between your system and QuickBooks Desktop. Our trained QuickBooks professionals are capable of solving this and all the related errors to keep you covered for your accounting needs. So, you do not have to fret the next time you come across this error, just get in touch with one of our technicians and get it done within no time. You’ll be given multiple solutions to troubleshoot the error. If you still cannot do it, you can let us do it by availing one of our paid plans.

We are a team of highly experienced WP professionals with remarkable knowledge. We lend our expertise to SMEs by providing them WordPressSupport services at affordable prices. Check out our WP Website Maintenance Plans.

Whether it is handling QuickBooks Mac Installation issues, checking the version for liability, handling Payroll management, or providing our clients with Remote help for troubleshooting their problems, we at QuickBooks Support Expert cover all aspects when offering QuickBooks Mac support.

Tinggalkan Balasan

Alamat email Anda tidak akan dipublikasikan. Ruas yang wajib ditandai *

This site uses Akismet to reduce spam. Learn how your comment data is processed.